<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":1,"applicationTime":274,"agent":""}</script>
<script type="text/javascript">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</script>
<script>
  var googleAnalyticsId = "UA-81785700-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>SpartanMag.com  -  Slump Buster: Langford finds his shot </title>
<meta content='SpartanMag.com  -  Slump Buster: Langford finds his shot ' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-1799fc286a65bd6e618a173906afb32ac0ee785bffdfb588c355d039d145cad1.css" />

<script src="https://cdn.rivals.com/production/assets/application-a2c345a5a66333346e4724c601a0c6601acd1f184e5f23345783d990aa532643.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="qMHo4WXePVdAT9YihzcisiMygaFjVhZDTvsoaIaPlzT85NkbJhIry4Tj6kAwkXGNXpIg576ES/lUE2amYXRfIA==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://michiganstate.rivals.com/news/slump-buster-langford-finds-his-shot' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/ce7jvtmwtqrzlml59wdp' property='og:image'>
<meta content='DETROIT – Josh Langford picked the perfect time to break his scoring drought against upset-minded Bucknell. ' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-03-16 23:00:01 -0500' property='article:published_time'>
<meta content='2018-03-17 03:32:44 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "michiganstate.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='michiganstate contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .michiganstate #programming > h1 {
      background-color: #023125 !important; } }
  .michiganstate > header .notification-link .count-container {
    background-color: #023125 !important; }
  .michiganstate > header .wrapper-container {
    background-color: #023125 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .michiganstate > header .wrapper-container {
        border-bottom: 5px solid #275e50 !important; } }
  .michiganstate > header .invalid-email-banner {
    background-color: #023125;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .michiganstate > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .michiganstate > header .invalid-email-banner a:hover {
      color: #275e50; }
  @media screen and (max-width: 767px) {
    .michiganstate > header .mobile-header {
      background-color: #275e50 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .michiganstate > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .michiganstate > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .michiganstate > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .michiganstate > header .nav-row > ul,
    .michiganstate > header .third-nav {
      background-color: white !important; }
    .michiganstate > header .dropdown-toggle > i.fa {
      color: #023125 !important; } }
  .michiganstate > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #023125; }
  
  .site-primary-font-color {
    color: #023125; }
  
  .site-primary-background-color {
    background-color: #023125; }
  
  .site-secondary-font-color {
    color: #275e50; }
  
  .site-secondary-background-color {
    background-color: #275e50; }
  
  :root {
    --outbrain-primary-color: #023125;
    --outbrain-secondary-color: #275e50; }
</style>

<header><nav ng-class='currentUser ? "signed-in" : "signed-out"' ng-controller='NavController' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='toggleContentNav($event)'></a>
      <a alt="Michigan State" class="school-header" href="//MichiganState.rivals.com"><img src="https://res-4.cloudinary.com/rivals/image/upload/wu47fj2pc97scxcozlbg" alt="Wu47fj2pc97scxcozlbg" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{subscribePath}}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current-user='currentUser'></rv-user-dropdown>
        <rv-forums-info current-user='currentUser' ng-if='currentUser && (isDesktop || isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!isTablet'>
      <ul>
        <li class="home top-nav"><a href="//MichiganState.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;michiganstate&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="currentUser" ng-if="!isTablet &amp;&amp; !isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='isTablet'>
      <ul>
        <li class="home top-nav"><a href="//MichiganState.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;michiganstate&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="currentUser" ng-if="!isTablet &amp;&amp; !isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='showEmailUpdateBanner'>
      <a ng-href='{{userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733115,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Slump Buster: Langford finds his shot "
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='@Rivals' name='twitter:site'>
<meta content='Slump Buster: Langford finds his shot ' name='twitter:title'>
<meta content='DETROIT – Josh Langford picked the perfect time to break his scoring drought against upset-minded Bucknell. ' name='twitter:description'>
<meta content='https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ce7jvtmwtqrzlml59wdp' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1905005,"title":"V-Cast: Michigan State answers tricky test from Bucknell","slug":"v-cast-michigan-state-answers-tricky-test-from-bucknell","kind":"premium","site_id":78,"sport":"basketball","news_type":"team","content_type":"Content::Link","live_at":"2018-03-17T01:29:38.276-05:00","summary":"DETROIT - Comp and PK weigh in on Michigan State&#x0027;s 82-78 win over Bucknell. ","deleted":false,"author_name":"Paul Konyndyk","author_title":"Associate Editor ","permalink":"https://michiganstate.forums.rivals.com/threads/post-game-v-cast-on-front-link.162991/","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1905000,"title":"Bridges: Locker Room Re-Mix","slug":"bridges-locker-room-re-mix","kind":"free","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-17T00:54:10.174-05:00","summary":"Miles Bridges discusses his 29-point performance against Bucknell and how &#x0027;a dunk can make anybody go off.&#x0027;","deleted":false,"author_name":"Jim Comparoni","author_title":"Publisher","permalink":"https://michiganstate.forums.rivals.com/threads/bridges-locker-room-re-mix-29-pts-vs-bucknell.162988/","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1905002,"title":"Tillman, Carter play key minutes off bench against Bucknell","slug":"tillman-carter-play-key-minutes-off-bench-against-bucknell","kind":"premium","site_id":78,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-17T01:26:12.886-05:00","summary":"DETROIT – Xavier Tillman, Ben Carter, provided well in relief against Bucknell. Could play more moving forward.","deleted":false,"author_name":"Paul Konyndyk","author_title":"Associate Editor ","permalink":"https://michiganstate.rivals.com/news/tillman-carter-play-key-minutes-off-bench-against-bucknell","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1905014,"title":"Izzo, Players Post-Game Press Conference","slug":"izzo-players-post-game-press-conference-3","kind":"premium","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-17T03:31:50.947-05:00","summary":"Tom Izzo, Miles Bridges, Cassius Winston and Joshua Langford discuss MSU&#x0027;s victory over Bucknell. ","deleted":false,"author_name":"Jim Comparoni","author_title":"Publisher","permalink":"https://michiganstate.forums.rivals.com/threads/izzo-players-post-game-press-conference-after-bucknell-victory.162995/","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1905010,"title":"Cassius: Locker Room Re-Mix","slug":"cassius-locker-room-re-mix","kind":"premium","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-17T02:30:08.621-05:00","summary":"Cassius Winston talks about fighting for \"games down the road,\" and Mike Garland gets cranky. ","deleted":false,"author_name":"Jim Comparoni","author_title":"Publisher","permalink":"https://michiganstate.forums.rivals.com/threads/check-out-coach-o-g-in-this-locker-room-talk.162994/","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904948,"title":"Spartans turn back Bucknell, will face Syracuse next","slug":"spartans-turn-back-bucknell-advance-to-second-round","kind":"free","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-16T20:33:09.756-05:00","summary":"DETROIT - Miles Bridges turned in memorable 29-point performance during an uncommonly green night in The Motor City.","deleted":false,"author_name":"Jim Comparoni","author_title":"Publisher","permalink":"https://michiganstate.rivals.com/news/spartans-turn-back-bucknell-advance-to-second-round","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904970,"title":"Audio: Izzo, Players Post-Game Press Conference","slug":"audio-izzo-players-post-game-press-conference-2","kind":"premium","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-16T22:24:18.437-05:00","summary":"DETROIT - Tom Izzo, Miles Bridges, Cassius Winston and Joshua Langford take questions on MSU&#x0027;s victory over Bucknell. ","deleted":false,"author_name":"Jim Comparoni","author_title":"Publisher","permalink":"https://michiganstate.forums.rivals.com/threads/izzo-players-post-bucknell-press-conference.162957/","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904920,"title":"LIVE game thread at SpartanMag","slug":"live-in-game-blog-at-spartanmag","kind":"premium","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-16T18:38:06.581-05:00","summary":"Comp \u0026 a cast of thousands chime in with thoughts while MSU vs Bucknell game is being played at Final Fourum msg board. ","deleted":false,"author_name":"Jim Comparoni","author_title":"Publisher","permalink":"https://michiganstate.forums.rivals.com/threads/official-game-thread-ncaa-tournament-first-round-msu-vs-bucknell.162893/","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904610,"title":"The 3-2-1 from Little Caesars Arena","slug":"the-3-2-1-from-little-caesars-arena","kind":"free","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-15T20:37:32.415-05:00","summary":"Three things we learned in the hours leading up to MSU&#x0027;s game against Bucknell, two questions and a prediction. ","deleted":false,"author_name":"Jim Comparoni","author_title":"Publisher","permalink":"https://michiganstate.rivals.com/news/the-3-2-1-from-little-caesars-arena","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904738,"title":"Elite 2020 recruit visiting MSU","slug":"elite-2020-recruit-visiting-msu","kind":"premium","site_id":78,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-16T09:10:38.696-05:00","summary":"One of the top prospects in tehnation for teh clkass of 202 is offensive tackle Paris Johnson Jr of St Xaxier High","deleted":false,"author_name":"Matt Dorsey","author_title":"Recruiting Analyst","permalink":"https://michiganstate.rivals.com/news/elite-2020-recruit-visiting-msu","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904612,"title":"Jackson on Thomas match-up: &#x0027;he&#x0027;s a scorer at all three levels&#x0027;","slug":"jackson-on-thomas-match-up-he-s-a-scorer-at-all-three-levels-","kind":"premium","site_id":78,"sport":"basketball","news_type":"team","content_type":"Content::Link","live_at":"2018-03-15T20:40:04.452-05:00","summary":"EAST LANSING - MSU freshman Jaren Jackson Jr. has his work cut out for him on defense against Bucknell&#x0027;s Zach Thomas. ","deleted":false,"author_name":"Paul Konyndyk","author_title":"Associate Editor ","permalink":"https://michiganstate.forums.rivals.com/threads/strong-interview-with-jaren-jackson-jr.162836/","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904568,"title":"V-Cast: Comp and PK check in from Little Caesar&#x0027;s Arena","slug":"v-cast-comp-and-pk-check-in-from-little-caesar-s-arena","kind":"premium","site_id":78,"sport":"basketball","news_type":"team","content_type":"Content::Link","live_at":"2018-03-15T18:18:57.501-05:00","summary":"DETROIT - Comp and PK check in following Michigan State&#x0027;s open practice at Little Caesar&#x0027;s Arena on Thursday. ","deleted":false,"author_name":"Paul Konyndyk","author_title":"Associate Editor ","permalink":"https://michiganstate.forums.rivals.com/threads/v-cast-comp-and-pk-check-in-from-little-caesars-arena.162822/","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904603,"title":"Poised for a break out? ","slug":"poised-for-a-break-out--1","kind":"premium","site_id":78,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-15T20:08:27.401-05:00","summary":"DETROIT - Michigan State could use scoring from Josh Langford, but he&#x0027;s providing other things in the meantime. ","deleted":false,"author_name":"Ricardo Cooney","author_title":"SpartanMag.com staff","permalink":"https://michiganstate.rivals.com/news/poised-for-a-break-out--1","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904587,"title":"Coach Perspective: Stephens on Bucknell","slug":"coach-perspective-stephens-on-bucknell","kind":"premium","site_id":78,"sport":"basketball","news_type":"team","content_type":"Content::Video","live_at":"2018-03-15T19:07:48.783-05:00","summary":"DETROIT - Associate Head Coach Dwayne Stephens shares Michigan State&#x0027;s keys for Bucknell. ","deleted":false,"author_name":"Paul Konyndyk","author_title":"Associate Editor ","permalink":"https://michiganstate.rivals.com/news/coach-perspective-stephens-on-bucknell","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904579,"title":"Bridges, Winston, Nairn today at Little Caesars Arena","slug":"bridges-winston-nairn-today-at-little-caesars-arena","kind":"free","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-15T18:52:58.232-05:00","summary":"Cassius Winston: \"If it&#x0027;s not a National Championship then it&#x0027;s probably a bust.\" ","deleted":false,"author_name":"Jim Comparoni","author_title":"Publisher","permalink":"https://michiganstate.forums.rivals.com/threads/bridges-tum-winston-today-at-little-caesars.162825/","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904565,"title":"Sights \u0026 Sounds from MSU Practice at Little Caesars Arena","slug":"more-sights-sounds-from-msu-practice-at-little-caesars-arena","kind":"premium","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-15T18:12:13.618-05:00","summary":"Chants of \"Go Green\" erupted while MSU worked on in-bound defense, transition defense, some shooting and dunking. ","deleted":false,"author_name":"Jim Comparoni","author_title":"Publisher","permalink":"https://michiganstate.forums.rivals.com/threads/more-sights-sounds-from-practice-today.162821/","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904524,"title":"Video: MSU practice at Little Caesars Arena","slug":"video-msu-practice-at-little-caesars-arena","kind":"premium","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-15T16:06:14.775-05:00","summary":"DETROIT - Video of MSU&#x0027;s dunk line, today at Little Caesars Arena. ","deleted":false,"author_name":"Jim Comparoni","author_title":"Publisher","permalink":"https://michiganstate.forums.rivals.com/threads/dunk-video-from-practice-today-at-little-caesars-arena.162814/","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904495,"title":"Video: Izzo&#x0027;s press conference from Little Caesars Arena","slug":"audio-izzo-s-press-conference-from-little-caesars-arena","kind":"premium","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-15T14:28:20.876-05:00","summary":"Listen to Tom Izzo&#x0027;s NCAA Tournament press conference, recorded at 3:05 p.m., Thursday in Detroit.","deleted":false,"author_name":"Jim Comparoni","author_title":"Publisher","permalink":"https://michiganstate.forums.rivals.com/threads/izzos-ncaa-tournament-press-conference-today-from-detroit.162828/","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904474,"title":"MSU&#x0027;s bench could provide big boost during weekend in Detroit ","slug":"bucknell-could-have-problems-matching-up-with-msu-s-bench","kind":"premium","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-15T13:39:17.071-05:00","summary":"DETROIT - Bench players such as Xavier Tillman could help make the difference in MSU&#x0027;s first-round matchup. ","deleted":false,"author_name":"Ricardo Cooney","author_title":"SpartanMag.com","permalink":"https://michiganstate.rivals.com/news/bucknell-could-have-problems-matching-up-with-msu-s-bench","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1903896,"title":"Winston: &#x0027;We&#x0027;re there with a mission&#x0027;","slug":"winston-we-re-on-a-mission-","kind":"premium","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-14T06:27:35.895-05:00","summary":"Cassius Winston discusses Bucknell match-ups and the Spartans&#x0027; mindset after practice, Tuesday.","deleted":false,"author_name":"Jim Comparoni","author_title":"Publisher","permalink":"https://michiganstate.forums.rivals.com/threads/winston-were-on-a-mission.162738/","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1904402,"title":"Spartans after 2-sport star","slug":"spartans-after-2-sport-star","kind":"premium","site_id":78,"sport":"football","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-03-15T10:50:47.392-05:00","summary":"Michigan State is looking at a player that could excel both on the gridiron and diamond. Jase Bowen of Toledo, Ohio is ","deleted":false,"author_name":"Josh Helmholdt","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/toledo-s-jase-bowen-replots-his-course","site_name":"SpartanMag.com","type":"Content","associated_links":[]},{"id":1903895,"title":"Bridges: &#x0027;We definitely have to crash (the boards)&#x0027;","slug":"bridges-we-definitely-have-to-crash-the-boards-","kind":"free","site_id":78,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-14T05:50:47.740-05:00","summary":"Miles Bridges is looking for ways to wring more production out of his talent, heading into the NCAA Tournament. ","deleted":false,"author_name":"SpartanMag.com","author_title":"SpartanMag.com","permalink":"https://michiganstate.rivals.com/news/bridges-we-definitely-have-to-crash-the-boards-","site_name":"SpartanMag.com","type":"Content","associated_links":[]}],nil,78,nil,nil,true); subdomain = &#x0027;michiganstate&#x0027;; aolPlayerId = &#x0027;59643ce0c214e371fad86089&#x0027;; aolCompanyId = &#x0027;595e5ac42a30cb7ee3e53929&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='facebook-ad-container horizontal'>
<div class='mobile-banner' style='display:none; position: relative;'>
<iframe style='display:none;'></iframe>
<script>
  var data = {
    placementid: '223720088042238_252396341841279',
    format: '320x50',
    testmode: false,
    onAdLoaded: function(element) {
      element.style.display = 'block';
    },
    onAdError: function(errorCode, errorMessage) {
    }
  };
  (function(w,l,d,t){var a=t();var b=d.currentScript||(function(){var c=d.getElementsByTagName('script');return c[c.length-1];})();var e=b.parentElement;e.dataset.placementid=data.placementid;var f=function(v){try{return v.document.referrer;}catch(e){}return'';};var g=function(h){var i=h.indexOf('/',h.indexOf('://')+3);if(i===-1){return h;}return h.substring(0,i);};var j=[l.href];var k=false;var m=false;if(w!==w.parent){var n;var o=w;while(o!==n){var h;try{m=m||(o.$sf&&o.$sf.ext);h=o.location.href;}catch(e){k=true;}j.push(h||f(n));n=o;o=o.parent;}}var p=l.ancestorOrigins;if(p){if(p.length>0){data.domain=p[p.length-1];}else{data.domain=g(j[j.length-1]);}}data.url=j[j.length-1];data.channel=g(j[0]);data.width=screen.width;data.height=screen.height;data.pixelratio=w.devicePixelRatio;data.placementindex=w.ADNW&&w.ADNW.Ads?w.ADNW.Ads.length:0;data.crossdomain=k;data.safeframe=!!m;var q={};q.iframe=e.firstElementChild;var r='https://www.facebook.com/audiencenetwork/web/?sdk=5.3';for(var s in data){q[s]=data[s];if(typeof(data[s])!=='function'){r+='&'+s+'='+encodeURIComponent(data[s]);}}q.iframe.src=r;q.tagJsInitTime=a;q.rootElement=e;q.events=[];w.addEventListener('message',function(u){if(u.source!==q.iframe.contentWindow){return;}u.data.receivedTimestamp=t();if(this.sdkEventHandler){this.sdkEventHandler(u.data);}else{this.events.push(u.data);}}.bind(q),false);q.tagJsIframeAppendedTime=t();w.ADNW=w.ADNW||{};w.ADNW.Ads=w.ADNW.Ads||[];w.ADNW.Ads.push(q);w.ADNW.init&&w.ADNW.init(q);})(window,location,document,Date.now||function(){return+new Date;});
</script>
<script async src='https://connect.facebook.net/en_US/fbadnw.js' type='text/javascript'></script>
</div>

</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #023125'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if>
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad' ng-if='true'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad' ng-if='true'></div>
<div class='side-rail-meta lrec-ad' ng-if='true'></div>

<rv-homepage-forums ad-referer='https://michiganstate.rivals.com/news/slump-buster-langford-finds-his-shot' background-color='#023125' base-api-url='https://michiganstate.forums.rivals.com/' homepage='false' message-board-url='michiganstate.forums.rivals.com' pub-ad='null' size='size' space-id='2022733115' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://michiganstate.rivals.com/news/slump-buster-langford-finds-his-shot/printable' site-name='SpartanMag.com'></rv-share-links>
</div>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-03-16 23:00:01 -0500') }}</span>
<span class='article-header-sport'>basketball</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1904978/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Slump Buster: Langford finds his shot </h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='title-sm'>
Paul Konyndyk
&bull;
</span>
<span class='type-sm'>SpartanMag.com</span>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Associate Editor </span>
</span>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='upsell'>
<div class='upsell-content'>
<div class='row premium-divider'>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
<div class='premium-content col-sm-8 col-xs-12'>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span>Premium Content</span>
</div>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
</div>
<h3 class='upsell-headline'>Subscribe today to read the full article and get everything Rivals has to offer.</h3>
<div class='row buttons'>
<div class='col-xs-24 col-sm-12'>
<div class='subscribe'>
<a class="btn" href="/sign_up?preselected_site_id=78">Subscribe to Rivals</a>
</div>
</div>
<div class='sign-in col-xs-24 col-sm-12'>
<a class="btn" href="/users/sign_in">Sign in</a>
</div>
</div>
<div class='value-props row'>
<ul>
<li class='value-prop fa-before fa-check'>Member-only message boards</li>
<li class='value-prop fa-before fa-check'>Exclusive highlights and recruiting interviews</li>
<li class='value-prop fa-before fa-check'>Exclusive coverage of Rivals Camp Series</li>
<li class='value-prop fa-before fa-check'>Breaking recruiting news</li>
</ul>
</div>
</div>
<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>

</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://michiganstate.rivals.com/news/slump-buster-langford-finds-his-shot/printable' site-name='SpartanMag.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":3}]' hide-yahoo-ad='false' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' site='{"id":78,"legacy_id":951,"name":"SpartanMag.com","friendly_name":"Michigan State","annual_discount":null,"subdomain":"michiganstate","primary_color":"023125","secondary_color":"275e50","font_color":"ffffff","short_name":"MichiganState","maple_ncaaf_team_id":30,"maple_ncaaf_endpoint":"ncaaf/teams/mml","maple_ncaab_team_id":358,"maple_ncaab_endpoint":"ncaab/teams/may","maple_college_id":30,"google_analytics_id":"UA-81785700-1"}' twitter-feed='{"id":78,"site_id":78,"handle":null,"list_name":null,"created_at":"2016-02-01T12:25:06.612-06:00","updated_at":"2016-02-01T12:25:06.612-06:00","hashtags":[],"usernames":[],"max_number":null}' yahoo-ad-present></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://michiganstate.rivals.com/news/slump-buster-langford-finds-his-shot/printable' site-name='SpartanMag.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733115', 'https://michiganstate.rivals.com/news/slump-buster-langford-finds-his-shot');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Slump Buster: Langford finds his shot ";
  _sf_async_config.sections = 'content,content-basketball,content-basketball-premium,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer') &amp;&amp; true &amp;&amp; (true)">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://michiganstate.rivals.com' data-widget-id='AR_4' ng-if='true'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='https://n.rivals.com/news/terms-of-service'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733115",
    c7: "https://michiganstate.rivals.com/news/slump-buster-langford-finds-his-shot"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fmichiganstate.rivals.com%2Fnews%2Fslump-buster-langford-finds-his-shot&c5=2022733115&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
